Network Design and Validation | Assignment

Verified

Added on  2022/09/15

|14
|2503
|16
AI Summary

Contribute Materials

Your contribution can guide someone’s learning journey. Share your documents today.
Document Page
Running head: NETWORK DESIGN AND VALIDATION
Network Design and Validation
Name of the Student
Name of the University
Author Note

Secure Best Marks with AI Grader

Need help grading? Try our AI Grader for instant feedback on your assignments.
Document Page
1NETWORK DESIGN AND VALIDATION
Design and draw network topology using packet tracers (or other drawing
tools). Clearly label the buildings, departments, switches and router. (10
marks)
Logical Network Diagram
Figure 1: Network topology diagram showing network components and layout
Identify how many subnets are required for your proposed topology.
Design the subnets based on the given network address (172.84.0.0/16) to
optimize the address spaces (using the second approach – number of hosts
needed).
Subnet Classification and IP Addressing
Subnet
Names
Size
Required
Size
Allocated
Sport 3 6
Health 3 6
Business 3 6
Engineerin
g
3 6
HR 4 6
Edge-R0 2 2
Document Page
2NETWORK DESIGN AND VALIDATION
Edge-R1
2 2
Sport
Allocated subnet/Mask 255.255.255.248 /29
Network address 172.84.10.0
Default gateway address 172.84.10.1
Valid host address range 172.84.10.1 - 172.84.10.6
Broadcast address 172.84.10.7
Health
Allocated subnet/Mask 255.255.255.248 /29
Network address 172.84.20.0
Default gateway address 172.84.20.1
Valid host address range 172.84.20.1 - 172.84.20.6
Broadcast address 172.84.20.7
Business
Allocated subnet/Mask 255.255.255.248 /29
Network address 172.84.30.0
Default gateway address 172.84.30.1
Valid host address range 172.84.30.1 - 172.84.30.6
Broadcast address 172.84.30.7
Engineering
Allocated subnet/Mask 255.255.255.248 /29
Network address 172.84.40.0
Default gateway address 172.84.40.1
Valid host address range 172.84.40.1 - 172.84.40.6
Broadcast address 172.84.40.7
HR
Allocated subnet/Mask 255.255.255.248 /29
Network address 172.84.50.0
Document Page
3NETWORK DESIGN AND VALIDATION
Default gateway address 172.84.50.1
Valid host address range 172.84.50.1 - 172.84.50.6
Broadcast address 172.84.50.7
Label the drawn network topology with corresponding subnets and ip
addresses and then take screenshot
Physical Network Diagram
Figure 2: Network Topology diagram showing subnet classification and IP addressing
Design appropriate configuration script for Routers and Switches to
implement the proposed network. Where necessary, our configuration
design should account for VLAN, Routing, NAT, and Redundancy.
Configuration of Router
Router6
Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int fa0/1.10
Router(config-subif)#
%LINK-5-CHANGED: Interface FastEthernet0/0.10, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface
FastEthernet0/1.10, changed state to up
Router(config-subif)#exit

Secure Best Marks with AI Grader

Need help grading? Try our AI Grader for instant feedback on your assignments.
Document Page
4NETWORK DESIGN AND VALIDATION
Router(config)#int fa0/1.10
Router(config-subif)#encap dot1q 10
Router(config-subif)#ip address 172.84.10.1 255.255.255.248
Router(config-subif)#int fa0/1.20
Router(config-subif)#
%LINK-5-CHANGED: Interface FastEthernet0/1.20, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface
FastEthernet0/1.20, changed state to up
Router(config-subif)#encap dot1q 20
Router(config-subif)#ip address 172.84.20.1 255.255.255.248
Router(config-subif)#int fa0/1.30
Router(config-subif)#
%LINK-5-CHANGED: Interface FastEthernet0/1.30, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface
FastEthernet0/1.30, changed state to up
Router(config-subif)#encap dot1q 30
Router(config-subif)#ip address 172.84.30.1 255.255.255.248
Router(config-subif)#int fa0/1.40
Router(config-subif)#
%LINK-5-CHANGED: Interface FastEthernet0/1.40, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface
FastEthernet0/1.40, changed state to up
Router(config-subif)#encap dot1q 40
Router(config-subif)#ip address 172.84.40.1 255.255.255.248
Router(config-subif)#int fa0/1.50
Router(config-subif)#
%LINK-5-CHANGED: Interface FastEthernet0/1.50, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface
FastEthernet0/1.50, changed state to up
Router(config-subif)#encap dot1q 50
Router(config-subif)#ip address 172.84.50.1 255.255.255.248
Router(config-subif)#int fa0/1.60
Router(config-subif)#
%LINK-5-CHANGED: Interface FastEthernet0/1.50, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface
FastEthernet0/1.50, changed state to up
Router(config-subif)#encap dot1q 60
Router(config-subif)#ip address 172.84.60.1 255.255.255.248
Router(config-subif)#exit
Router(config)#ip dhcp pool 10
Document Page
5NETWORK DESIGN AND VALIDATION
Router(dhcp-config)#network 172.84.10.0 255.255.255.248
Router(dhcp-config)#default-router 172.84.10.1
Router(dhcp-config)#ip dhcp pool 20
Router(dhcp-config)#network 172.84.20.0 255.255.255.248
Router(dhcp-config)#default-router 172.84.20.1
Router(dhcp-config)#ip dhcp pool 30
Router(dhcp-config)#network 172.84.30.0 255.255.255.248
Router(dhcp-config)#default-router 172.84.30.1
Router(dhcp-config)#ip dhcp pool 40
Router(dhcp-config)#network 172.84.40.0 255.255.255.248
Router(dhcp-config)#default-router 172.84.40.1
Router(dhcp-config)#ip dhcp pool 50
Router(dhcp-config)#network 172.84.50.0 255.255.255.248
Router(dhcp-config)#default-router 172.84.50.1
Router(dhcp-config)#ip dhcp pool 60
Router(dhcp-config)#network 172.84.60.0 255.255.255.248
Router(dhcp-config)#default-router 172.84.60.1
Router(dhcp-config)#exit
Router(config)#^Z
Router#
%SYS-5-CONFIG_I: Configured from console by console
Router#wr
Building configuration...
[OK]
Configuration of Multilayer Switch
Multilayer Switch1
Switch>enable
Switch#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#vlan 10
Switch(config-vlan)#name Sport
Switch(config-vlan)#exit
Switch(config)#vlan 20
Switch(config-vlan)#name Health
Switch(config-vlan)#exit
Switch(config)#vlan 30
Switch(config-vlan)#name Business
Switch(config-vlan)#exit
Switch(config)#vlan 40
Switch(config-vlan)#name Engineering
Switch(config-vlan)#exit
Switch(config)#vlan 50
Switch(config-vlan)#name HR
Switch(config-vlan)#exit
Document Page
6NETWORK DESIGN AND VALIDATION
Switch(config)#
Switch(config)#interface FastEthernet0/1
Switch(config-if)#
Switch(config-if)#switchport mode trunk
Switch(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1,
changed state to down
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1,
changed state to up
Switch#
%SYS-5-CONFIG_I: Configured from console by console
Switch#
Switch(config)#interface FastEthernet0/2
Switch(config-if)#
Switch(config-if)#switchport mode trunk
Switch(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2,
changed state to down
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2,
changed state to up
Switch#
%SYS-5-CONFIG_I: Configured from console by console
Switch#
Switch(config)#interface FastEthernet0/3
Switch(config-if)#
Switch(config-if)#switchport mode trunk
Switch(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/3,
changed state to down
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/3,
changed state to up
Switch#
%SYS-5-CONFIG_I: Configured from console by console
Switch#
Switch(config)#interface FastEthernet0/4
Switch(config-if)#
Switch(config-if)#switchport mode trunk
Switch(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/4,
changed state to down

Paraphrase This Document

Need a fresh take? Get an instant paraphrase of this document with our AI Paraphraser
Document Page
7NETWORK DESIGN AND VALIDATION
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/4,
changed state to up
Switch#
%SYS-5-CONFIG_I: Configured from console by console
Switch#
Switch(config)#interface FastEthernet0/5
Switch(config-if)#
Switch(config-if)#switchport mode trunk
Switch(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/5,
changed state to down
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/5,
changed state to up
Switch#
%SYS-5-CONFIG_I: Configured from console by console
Switch#
Switch(config)#interface FastEthernet0/6
Switch(config-if)#
Switch(config-if)#switchport mode trunk
Switch(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/6,
changed state to down
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/6,
changed state to up
Switch#
%SYS-5-CONFIG_I: Configured from console by console
Switch#
Switch(config)#interface FastEthernet0/7
Switch(config-if)#
Switch(config-if)#switchport mode trunk
Switch(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/7,
changed state to down
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/7,
changed state to up
Switch#
%SYS-5-CONFIG_I: Configured from console by console
Switch#
Document Page
8NETWORK DESIGN AND VALIDATION
Layer2 Switch1
Switch>enable
Switch#configure terminal
Enter configuration commands, one per line. End with
CNTL/Z.
Switch(config)#vlan 10
Switch(config-vlan)#name Sport
Switch(config-vlan)#exit
Switch(config)#vlan 20
Switch(config-vlan)#name Health
Switch(config-vlan)#exit
Switch(config)#
Switch(config)#interface FastEthernet0/2
Switch(config-if)#switchport access vlan 10
Switch(config-if)#exit
Switch(config)#interface FastEthernet0/3
Switch(config-if)#switchport access vlan 20
Switch(config-if)#exit
Switch(config)#interface FastEthernet0/1
Switch(config-if)#
Switch(config-if)#switchport mode trunk
Switch(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to
down
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up
Switch(config-if)#exit
Switch(config)#interface FastEthernet0/4
Switch(config-if)#
Switch(config-if)#switchport mode trunk
Switch(config-if)#
Switch(config-if)#exit
Document Page
9NETWORK DESIGN AND VALIDATION
Perform necessary verification to test the performance of the proposed
network. All computers should be able to ping to any other computers on
different networks and to the port on router. If either of the Layer 3
switches fails, the network should still be functional.
Use necessary screenshots of ping and show commands on computers, switches
and routers to show the status and performance of your network.
The validation tests of packet transmissions performed using the ICMP protocol between
computers, servers and the router are given below:
This screenshot shows successful transfer of ICMP packets between the computer of
Sport department with the computers of all other departments. This proves that the inter
VLAN routing is properly set up and enables internetwork communications between the
different network segments.
This screenshot shows successful transfer of ICMP packets between the computer of
Health department with the computers of all other departments. This proves that the inter
VLAN routing is properly set up and enables internetwork communications between the
different network segments.

Secure Best Marks with AI Grader

Need help grading? Try our AI Grader for instant feedback on your assignments.
Document Page
10NETWORK DESIGN AND VALIDATION
This screenshot shows successful transfer of ICMP packets between the computer of
Business department with the computers of all other departments. This proves that the inter
VLAN routing is properly set up and enables internetwork communications between the
different network segments.
This screenshot shows successful transfer of ICMP packets between the computer of
Engineering department with the computers of all other departments. This proves that the
inter VLAN routing is properly set up and enables internetwork communications between the
different network segments.
This screenshot shows successful transfer of ICMP packets between the computer of
HR department with the computers of all other departments. This proves that the inter VLAN
routing is properly set up and enables internetwork communications between the different
network segments.
Document Page
11NETWORK DESIGN AND VALIDATION
This screenshot shows successful transfer of ICMP packets between the computer of
one department with the servers of all other departments. This proves that the inter VLAN
routing is properly set up and enables internetwork communications between the different
network segments.
This screenshot shows successful transfer of ICMP packets between the Router6 and
computers of all other departments. This proves that the inter VLAN routing is properly set
up and enables internetwork communications between the different network segments. This
proves that the inter VLAN routing is properly set up and enables internetwork
communications between the different network segments.
This screenshot shows successful transfer of ICMP packets between the Router6 and
the servers of all other departments. This proves that the inter VLAN routing is properly set
up and enables internetwork communications between the different network segments.
Document Page
12NETWORK DESIGN AND VALIDATION
Bibliography
Al-Khalidi, M., Thomos, N., Reed, M.J., Al-Naday, M.F. and Trossen, D., 2018. Anchor free
IP mobility. IEEE Transactions on Mobile Computing, 18(1), pp.56-69.
Christopher, G.E. and Jack, I.E.K.E., 2016. A model of local area network based application
for Inter-office communication. In Proceedings of the World Congress on Engineering and
Computer Science (Vol. 1, pp. 19-21).
Hill, K. and Gagneja, K., 2018, February. Concept network design for a young Mars science
station and Trans-planetary communication. In 2018 Fourth International Conference on
Mobile and Secure Services (MobiSecServ) (pp. 1-8). IEEE.
Hock, F. and Kortiš, P., 2015, November. Commercial and open-source based Intrusion
Detection System and Intrusion Prevention System (IDS/IPS) design for an IP networks. In
2015 13th International Conference on Emerging eLearning Technologies and Applications
(ICETA) (pp. 1-4). IEEE.
Iturbe, M., Garitano, I., Zurutuza, U. and Uribeetxeberria, R., 2016, February. Visualizing
Network Flows and Related Anomalies in Industrial Networks using Chord Diagrams and
Whitelisting. In VISIGRAPP (2: IVAPP) (pp. 101-108).
Lane, N., 2018. Development and integration of Honeywell’s One-Wireless network
(Doctoral dissertation, Murdoch University).
Ma, H., Lv, G. and Wu, C., 2018. Campus Network Planning and Design. Journal of
Computer Hardware Engineering (TRANSFERRED), 1(1).
Makarov, S.V., Abdulnazarov, F. and Anarbekov, O., 2016. The Development of the Routing
Pattern of the Backbone Data Transmission Network for the Automation of the Krasnoyarsk
Railway. Development, 7(6).

Paraphrase This Document

Need a fresh take? Get an instant paraphrase of this document with our AI Paraphraser
Document Page
13NETWORK DESIGN AND VALIDATION
Maximov, R.V., Ivanov, I.I. and Sharifullin, S.R., 2017, December. Network Topology
Masking in Distributed Information Systems. In Selected Papers of the VIII All-Russian
Conference with International Participation" Secure Information Technologies"(BIT (Vol. 6,
p. 83).
Voigt, S., Howard, C., Philp, D. and Penny, C., 2017, August. Representing and reasoning
about logical network topologies. In International Workshop on Graph Structures for
Knowledge Representation and Reasoning (pp. 73-83). Springer, Cham.
1 out of 14
circle_padding
hide_on_mobile
zoom_out_icon
[object Object]

Your All-in-One AI-Powered Toolkit for Academic Success.

Available 24*7 on WhatsApp / Email

[object Object]