Configuring Network Services using Cisco Packet Tracer
VerifiedAdded on  2019/11/20
|21
|1497
|169
Report
AI Summary
The assignment content focuses on the configuration of network services including DHCP, WEB Server, DNS, and Firewall. The provided router configuration demonstrates how to create an access list to deny or permit specific traffic flows. Additionally, the bibliography section provides a list of research articles and studies related to computer networking, Cisco Packet Tracer, and network simulation.
Contribute Materials
Your contribution can guide someone’s learning journey. Share your
documents today.
Running head: TCP/IP NETWORKING
TCP/IP Networking
Name of the Student
Name of the University
Author’s note
TCP/IP Networking
Name of the Student
Name of the University
Author’s note
Secure Best Marks with AI Grader
Need help grading? Try our AI Grader for instant feedback on your assignments.
1
TCP/IP NETWORKING
Executive Summary
The report is prepared for designing and configuring a network using multiple network interface that are
connected with routers. Two routers are used for designing the network and the client Pc are connected
with the interface of the first router and the servers are connected with the interface of the second
router. Three routers are installed in the network such as the DHCP, Web server and the DNS server. The
DHCP server is used for allocation of IP address to the client machine connected with the interface on
the first router and the DNS server contains the IP address and the host name of the network and used
for communication with the client. The web server is configured with HTTP for serving the client users
with the webpages and respond to their request. A firewall is configured in the network to block one of
the client PC to access the WEB server and the screenshots are attached in the document.
TCP/IP NETWORKING
Executive Summary
The report is prepared for designing and configuring a network using multiple network interface that are
connected with routers. Two routers are used for designing the network and the client Pc are connected
with the interface of the first router and the servers are connected with the interface of the second
router. Three routers are installed in the network such as the DHCP, Web server and the DNS server. The
DHCP server is used for allocation of IP address to the client machine connected with the interface on
the first router and the DNS server contains the IP address and the host name of the network and used
for communication with the client. The web server is configured with HTTP for serving the client users
with the webpages and respond to their request. A firewall is configured in the network to block one of
the client PC to access the WEB server and the screenshots are attached in the document.
2
TCP/IP NETWORKING
Table of Contents
Task 1: Setting up a Network..........................................................................................................3
1.1. Configuration of the PC, Server and Router interface.........................................................3
1.2. Configuration of the router.................................................................................................7
1.3. Pinging from the client end.................................................................................................9
1.4. Traceroute command from the client to the server..........................................................13
Task 2- Configuration of the network service...............................................................................14
2.1. DHCP..................................................................................................................................14
2.2. WEB Server........................................................................................................................14
2.3. DNS....................................................................................................................................15
2.4. Firewall..............................................................................................................................16
Bibliography..................................................................................................................................18
TCP/IP NETWORKING
Table of Contents
Task 1: Setting up a Network..........................................................................................................3
1.1. Configuration of the PC, Server and Router interface.........................................................3
1.2. Configuration of the router.................................................................................................7
1.3. Pinging from the client end.................................................................................................9
1.4. Traceroute command from the client to the server..........................................................13
Task 2- Configuration of the network service...............................................................................14
2.1. DHCP..................................................................................................................................14
2.2. WEB Server........................................................................................................................14
2.3. DNS....................................................................................................................................15
2.4. Firewall..............................................................................................................................16
Bibliography..................................................................................................................................18
3
TCP/IP NETWORKING
Task 1: Setting up a Network
1.1. Configuration of the PC, Server and Router interface
Configuration of the PC0
Configuration of the PC1
TCP/IP NETWORKING
Task 1: Setting up a Network
1.1. Configuration of the PC, Server and Router interface
Configuration of the PC0
Configuration of the PC1
Secure Best Marks with AI Grader
Need help grading? Try our AI Grader for instant feedback on your assignments.
4
TCP/IP NETWORKING
Configuration of the WEB server
Configuration of the DHCP server
TCP/IP NETWORKING
Configuration of the WEB server
Configuration of the DHCP server
5
TCP/IP NETWORKING
Configuration of the DNS server
Configuration of the router interface
Router 1
TCP/IP NETWORKING
Configuration of the DNS server
Configuration of the router interface
Router 1
6
TCP/IP NETWORKING
Router 2
TCP/IP NETWORKING
Router 2
Paraphrase This Document
Need a fresh take? Get an instant paraphrase of this document with our AI Paraphraser
7
TCP/IP NETWORKING
1.2. Configuration of the router
Router 1 configuration:
Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interface FastEthernet0/0
Router(config-if)#ip address 192.168.1.1 255.255.255.0
Router(config-if)#
Router(config-if)#exit
Router(config)#interface Serial0/3/0
TCP/IP NETWORKING
1.2. Configuration of the router
Router 1 configuration:
Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interface FastEthernet0/0
Router(config-if)#ip address 192.168.1.1 255.255.255.0
Router(config-if)#
Router(config-if)#exit
Router(config)#interface Serial0/3/0
8
TCP/IP NETWORKING
Router(config-if)#ip address 192.168.2.1 255.255.255.252
Router(config-if)#exit
Router(config)#ip route 192.168.3.0 255.255.255.0 192.168.2.2
Router(config)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to down
Router 2 configuration:
Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interface Serial0/3/0
Router(config-if)#ip address 192.168.2.2 255.255.255.252
Router(config-if)#
Router(config-if)#exit
Router(config)#interface FastEthernet0/0
Router(config-if)#ip address 192.168.3.1 255.255.255.0
Router(config-if)#
Router(config-if)#exit
Router(config)#ip route 192.168.1.0 255.255.255.0 192.168.2.1
Router(config)#
TCP/IP NETWORKING
Router(config-if)#ip address 192.168.2.1 255.255.255.252
Router(config-if)#exit
Router(config)#ip route 192.168.3.0 255.255.255.0 192.168.2.2
Router(config)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to down
Router 2 configuration:
Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interface Serial0/3/0
Router(config-if)#ip address 192.168.2.2 255.255.255.252
Router(config-if)#
Router(config-if)#exit
Router(config)#interface FastEthernet0/0
Router(config-if)#ip address 192.168.3.1 255.255.255.0
Router(config-if)#
Router(config-if)#exit
Router(config)#ip route 192.168.1.0 255.255.255.0 192.168.2.1
Router(config)#
9
TCP/IP NETWORKING
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to down
1.3. Pinging from the client end
Ping the client's own network interface
TCP/IP NETWORKING
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to down
1.3. Pinging from the client end
Ping the client's own network interface
Secure Best Marks with AI Grader
Need help grading? Try our AI Grader for instant feedback on your assignments.
10
TCP/IP NETWORKING
Ping the local router gateway interface
Pinging the remote router interface
TCP/IP NETWORKING
Ping the local router gateway interface
Pinging the remote router interface
11
TCP/IP NETWORKING
Pinging the server
TCP/IP NETWORKING
Pinging the server
12
TCP/IP NETWORKING
TCP/IP NETWORKING
Paraphrase This Document
Need a fresh take? Get an instant paraphrase of this document with our AI Paraphraser
13
TCP/IP NETWORKING
1.4. Traceroute command from the client to the server
TCP/IP NETWORKING
1.4. Traceroute command from the client to the server
14
TCP/IP NETWORKING
Task 2- Configuration of the network service
2.1. DHCP
2.2. WEB Server
TCP/IP NETWORKING
Task 2- Configuration of the network service
2.1. DHCP
2.2. WEB Server
15
TCP/IP NETWORKING
2.3. DNS
TCP/IP NETWORKING
2.3. DNS
Secure Best Marks with AI Grader
Need help grading? Try our AI Grader for instant feedback on your assignments.
16
TCP/IP NETWORKING
2.4. Firewall
Router 1 Configuration:
Router(config)#access-list 101 deny tcp host 192.168.1.2 host 192.168.3.6 eq 80
Router(config)#access-list 101 permit ip any any
Router(config)#int fa 0/0
Router(config-if)#ip access-group 101 in
Router(config-if)#exit
TCP/IP NETWORKING
2.4. Firewall
Router 1 Configuration:
Router(config)#access-list 101 deny tcp host 192.168.1.2 host 192.168.3.6 eq 80
Router(config)#access-list 101 permit ip any any
Router(config)#int fa 0/0
Router(config-if)#ip access-group 101 in
Router(config-if)#exit
17
TCP/IP NETWORKING
TCP/IP NETWORKING
18
TCP/IP NETWORKING
Bibliography
Archana, C. (2015). Analysis of RIPv2, OSPF, EIGRP Configuration on router Using CISCO Packet tracer.
International Journal of Engineering Science and Innovative Technology (IJESIT) Volume, 4.
Bavarva, A., & Shrivastava, S. A. (2014). Design Concept and Simulation of Migration from Present IPv4
Network to Future IPv6 Network Using Three Transition Mechanisms. International Journal of
Engineering, 3(4).
Cai, W. X., Li, G. S., Chen, X. H., Hong, C. Q., Zhu, S. Z., Wu, Q. H., & Chen, R. (2016, August). Education
based new computer network simulator design and implementation. In Computer Science &
Education (ICCSE), 2016 11th International Conference on (pp. 933-935). IEEE.
Gill, J., & Zunnurhain, K. (2017, April). Determining the Penetration Threshold for an ASA 5500 Firewall.
In Proceedings of the SouthEast Conference (pp. 149-153). ACM.
Goyal, V., & Arora, G. (2017). Implementation of Enhanced Interior Gateway Routing Protocol (EIGRP) in
IPv6 Network. Research Journal of Advanced Engineering and Science, 2(1), 90-95.
Gusev, M., Ristov, S., & Donevski, A. (2014, April). Integrating practical CISCO CCNA courses in the
Computer Networks' curriculum. In Global Engineering Education Conference (EDUCON), 2014
IEEE (pp. 499-506). IEEE.
Herbert, B. M., & Wigley, G. B. (2015). The Role of Cisco Virtual Internet Routing Lab in network training
environments.
Hossain, M. A., Islam, M. M., & Majumder, M. N. U. (2016). Comparative Analysis of Two Prominent
Routing Protocols in IPv6 Network: OSPFv3 & EIGRPv6. International Journal of Computer (IJC),
22(1), 79-89.
TCP/IP NETWORKING
Bibliography
Archana, C. (2015). Analysis of RIPv2, OSPF, EIGRP Configuration on router Using CISCO Packet tracer.
International Journal of Engineering Science and Innovative Technology (IJESIT) Volume, 4.
Bavarva, A., & Shrivastava, S. A. (2014). Design Concept and Simulation of Migration from Present IPv4
Network to Future IPv6 Network Using Three Transition Mechanisms. International Journal of
Engineering, 3(4).
Cai, W. X., Li, G. S., Chen, X. H., Hong, C. Q., Zhu, S. Z., Wu, Q. H., & Chen, R. (2016, August). Education
based new computer network simulator design and implementation. In Computer Science &
Education (ICCSE), 2016 11th International Conference on (pp. 933-935). IEEE.
Gill, J., & Zunnurhain, K. (2017, April). Determining the Penetration Threshold for an ASA 5500 Firewall.
In Proceedings of the SouthEast Conference (pp. 149-153). ACM.
Goyal, V., & Arora, G. (2017). Implementation of Enhanced Interior Gateway Routing Protocol (EIGRP) in
IPv6 Network. Research Journal of Advanced Engineering and Science, 2(1), 90-95.
Gusev, M., Ristov, S., & Donevski, A. (2014, April). Integrating practical CISCO CCNA courses in the
Computer Networks' curriculum. In Global Engineering Education Conference (EDUCON), 2014
IEEE (pp. 499-506). IEEE.
Herbert, B. M., & Wigley, G. B. (2015). The Role of Cisco Virtual Internet Routing Lab in network training
environments.
Hossain, M. A., Islam, M. M., & Majumder, M. N. U. (2016). Comparative Analysis of Two Prominent
Routing Protocols in IPv6 Network: OSPFv3 & EIGRPv6. International Journal of Computer (IJC),
22(1), 79-89.
Paraphrase This Document
Need a fresh take? Get an instant paraphrase of this document with our AI Paraphraser
19
TCP/IP NETWORKING
Hsin, W. J. (2015, February). Learning computer networking through illustration. In Proceedings of the
46th ACM Technical Symposium on Computer Science Education (pp. 515-515). ACM.
Javid, S. R. (2014). Role of Packet Tracer in learning Computer Networks. International Journal of
Advanced Research in Computer and Communication Engineering, 3(5), 6508-6511.
Jesin, A. (2014). Packet Tracer Network Simulator. Packt Publishing Ltd.
Khedr, M. E., Zaghloul, M. S., & El-Desouky, M. I. (2015). Wireless Adhoc Multi Access Networks
Optimization Using OSPF Routing Protocol Based On Cisco Devices. International Journal of
Computer Networks & Communications, 7(2), 59.
Kumar, R. K. B. G. R. (2016). Network Packet Route Tracer for web request to find various intermediate
routers in networks. Network, 6(2).
Liu, M. (2014). Cisco Networking Academy: Next-Generation Assessments and Their Implications for K-
12 Education. Clayton Christensen Institute for Disruptive Innovation.
Oladipo, F. O., Madu, C. C., & Okoro, C. C. (2015). Re-Engineering Campus-Wide Internet Telephony
Using Voice over Internet Protocol. International Journal of Networks and Communications,
5(2), 23-30.
Prasad, N. H., Reddy, B. K., Amarnath, B., & Puthanial, M. (2016). Intervlan Routing and Various
Configurations on Vlan in a Network using Cisco Packet Tracer. International Journal for
Innovative Research in Science and Technology, 2(11), 749-758.
Sun, L., Wu, J., Zhang, Y., & Yin, H. (2013, April). Comparison between physical devices and simulator
software for Cisco network technology teaching. In Computer Science & Education (ICCSE), 2013
8th International Conference on (pp. 1357-1360). IEEE.
TCP/IP NETWORKING
Hsin, W. J. (2015, February). Learning computer networking through illustration. In Proceedings of the
46th ACM Technical Symposium on Computer Science Education (pp. 515-515). ACM.
Javid, S. R. (2014). Role of Packet Tracer in learning Computer Networks. International Journal of
Advanced Research in Computer and Communication Engineering, 3(5), 6508-6511.
Jesin, A. (2014). Packet Tracer Network Simulator. Packt Publishing Ltd.
Khedr, M. E., Zaghloul, M. S., & El-Desouky, M. I. (2015). Wireless Adhoc Multi Access Networks
Optimization Using OSPF Routing Protocol Based On Cisco Devices. International Journal of
Computer Networks & Communications, 7(2), 59.
Kumar, R. K. B. G. R. (2016). Network Packet Route Tracer for web request to find various intermediate
routers in networks. Network, 6(2).
Liu, M. (2014). Cisco Networking Academy: Next-Generation Assessments and Their Implications for K-
12 Education. Clayton Christensen Institute for Disruptive Innovation.
Oladipo, F. O., Madu, C. C., & Okoro, C. C. (2015). Re-Engineering Campus-Wide Internet Telephony
Using Voice over Internet Protocol. International Journal of Networks and Communications,
5(2), 23-30.
Prasad, N. H., Reddy, B. K., Amarnath, B., & Puthanial, M. (2016). Intervlan Routing and Various
Configurations on Vlan in a Network using Cisco Packet Tracer. International Journal for
Innovative Research in Science and Technology, 2(11), 749-758.
Sun, L., Wu, J., Zhang, Y., & Yin, H. (2013, April). Comparison between physical devices and simulator
software for Cisco network technology teaching. In Computer Science & Education (ICCSE), 2013
8th International Conference on (pp. 1357-1360). IEEE.
20
TCP/IP NETWORKING
Sunvy, M. M. I., & Majumder, M. N. U. (2016). Comparative Analysis of Two Prominent Routing Protocols
in IPv6 Network: OSPFv3 & EIGRPv6 (Doctoral dissertation, East West University).
Tagliacane, S. V., Prasad, P. W. C., Zajko, G., Elchouemi, A., & Singh, A. K. (2016, March). Network
simulations and future technologies in teaching networking courses: Development of a
laboratory model with Cisco Virtual Internet Routing Lab (Virl). In Wireless Communications,
Signal Processing and Networking (WiSPNET), International Conference on (pp. 644-649). IEEE.
Yan, D. (2014). Applications of Packet Tracer simulator in the course< Router Configuration. Electronic
Test, 8, 019.
TCP/IP NETWORKING
Sunvy, M. M. I., & Majumder, M. N. U. (2016). Comparative Analysis of Two Prominent Routing Protocols
in IPv6 Network: OSPFv3 & EIGRPv6 (Doctoral dissertation, East West University).
Tagliacane, S. V., Prasad, P. W. C., Zajko, G., Elchouemi, A., & Singh, A. K. (2016, March). Network
simulations and future technologies in teaching networking courses: Development of a
laboratory model with Cisco Virtual Internet Routing Lab (Virl). In Wireless Communications,
Signal Processing and Networking (WiSPNET), International Conference on (pp. 644-649). IEEE.
Yan, D. (2014). Applications of Packet Tracer simulator in the course< Router Configuration. Electronic
Test, 8, 019.
1 out of 21
Related Documents
Your All-in-One AI-Powered Toolkit for Academic Success.
 +13062052269
info@desklib.com
Available 24*7 on WhatsApp / Email
Unlock your academic potential
© 2024  |  Zucol Services PVT LTD  |  All rights reserved.