Network Simulation and Configuration
VerifiedAdded on  2020/04/07
|19
|918
|34
AI Summary
This assignment delves into network simulation and configuration using tools like Packet Tracer. Students are tasked with setting up a network environment comprising DHCP, a web server, DNS, and a firewall. The project involves comprehensive testing of network connectivity through ping commands and traceroute analysis from the client to the server. Configuration details for each network service and a router configuration are included.
Contribute Materials
Your contribution can guide someone’s learning journey. Share your
documents today.
Running head: TCP/IP NETWORKING
TCP/IP Networking
Name of the Student
Name of the University
Author’s note
TCP/IP Networking
Name of the Student
Name of the University
Author’s note
Secure Best Marks with AI Grader
Need help grading? Try our AI Grader for instant feedback on your assignments.
1
TCP/IP NETWORKING
Table of Contents
Task 1: Setting up a Network..........................................................................................................2
1.1. Configuration of the PC, Server and Router interface.........................................................2
1.2. Configuration of the router with IP packet forwarding.......................................................7
1.3. Pinging from the client end.................................................................................................8
1.4. Traceroute command from the client to the server..........................................................11
Task 2- Configuration of the network service...............................................................................12
2.1. DHCP..................................................................................................................................12
2.2. WEB Server........................................................................................................................13
2.3. DNS....................................................................................................................................14
2.4. Firewall..............................................................................................................................15
Bibliography..................................................................................................................................16
TCP/IP NETWORKING
Table of Contents
Task 1: Setting up a Network..........................................................................................................2
1.1. Configuration of the PC, Server and Router interface.........................................................2
1.2. Configuration of the router with IP packet forwarding.......................................................7
1.3. Pinging from the client end.................................................................................................8
1.4. Traceroute command from the client to the server..........................................................11
Task 2- Configuration of the network service...............................................................................12
2.1. DHCP..................................................................................................................................12
2.2. WEB Server........................................................................................................................13
2.3. DNS....................................................................................................................................14
2.4. Firewall..............................................................................................................................15
Bibliography..................................................................................................................................16
2
TCP/IP NETWORKING
Task 1: Setting up a Network
1.1. Configuration of the PC, Server and Router interface
Configuration of the PC0
Configuration of the PC1
TCP/IP NETWORKING
Task 1: Setting up a Network
1.1. Configuration of the PC, Server and Router interface
Configuration of the PC0
Configuration of the PC1
3
TCP/IP NETWORKING
Configuration of the WEB server
Configuration of the DHCP server
TCP/IP NETWORKING
Configuration of the WEB server
Configuration of the DHCP server
Secure Best Marks with AI Grader
Need help grading? Try our AI Grader for instant feedback on your assignments.
4
TCP/IP NETWORKING
Configuration of the DNS server
Configuration of the router interface
Router 0
TCP/IP NETWORKING
Configuration of the DNS server
Configuration of the router interface
Router 0
5
TCP/IP NETWORKING
Router 1
TCP/IP NETWORKING
Router 1
6
TCP/IP NETWORKING
Routing table of the routers
172.21.0.0/16 is variably subnetted, 3 subnets, 2 masks
TCP/IP NETWORKING
Routing table of the routers
172.21.0.0/16 is variably subnetted, 3 subnets, 2 masks
Paraphrase This Document
Need a fresh take? Get an instant paraphrase of this document with our AI Paraphraser
7
TCP/IP NETWORKING
C 172.21.1.0/24 is directly connected, FastEthernet0/0
C 172.21.2.0/30 is directly connected, Serial0/3/0
S 172.21.3.0/24 [1/0] via 172.21.2.2
172.21.0.0/16 is variably subnetted, 3 subnets, 2 masks
S 172.21.1.0/24 [1/0] via 172.21.2.1
C 172.21.2.0/30 is directly connected, Serial0/3/0
C 172.21.3.0/24 is directly connected, FastEthernet0/0
1.2. Configuration of the router with IP packet forwarding
Router 0 configuration:
Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interface FastEthernet0/0
Router(config-if)#ip address 172.21.1.1 255.255.255.0
Router(config-if)#
Router(config-if)#exit
Router(config)#interface Serial0/3/0
Router(config-if)#ip address 172.21.2.1 255.255.255.252
Router(config-if)#exit
TCP/IP NETWORKING
C 172.21.1.0/24 is directly connected, FastEthernet0/0
C 172.21.2.0/30 is directly connected, Serial0/3/0
S 172.21.3.0/24 [1/0] via 172.21.2.2
172.21.0.0/16 is variably subnetted, 3 subnets, 2 masks
S 172.21.1.0/24 [1/0] via 172.21.2.1
C 172.21.2.0/30 is directly connected, Serial0/3/0
C 172.21.3.0/24 is directly connected, FastEthernet0/0
1.2. Configuration of the router with IP packet forwarding
Router 0 configuration:
Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interface FastEthernet0/0
Router(config-if)#ip address 172.21.1.1 255.255.255.0
Router(config-if)#
Router(config-if)#exit
Router(config)#interface Serial0/3/0
Router(config-if)#ip address 172.21.2.1 255.255.255.252
Router(config-if)#exit
8
TCP/IP NETWORKING
Router(config)#ip route 172.21.3.0 255.255.255.0 172.21.2.2
Router 1 configuration:
Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interface Serial0/3/0
Router(config-if)#ip address 172.21.2.2 255.255.255.252
Router(config-if)#
Router(config-if)#exit
Router(config)#interface FastEthernet0/0
Router(config-if)#ip address 172.21.3.1 255.255.255.0
Router(config-if)#
Router(config-if)#exit
Router(config)#ip route 172.21.1.0 255.255.255.0 172.21.2.1
Router(config)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to down
1.3. Pinging from the client end
Ping the client's own network interface
TCP/IP NETWORKING
Router(config)#ip route 172.21.3.0 255.255.255.0 172.21.2.2
Router 1 configuration:
Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interface Serial0/3/0
Router(config-if)#ip address 172.21.2.2 255.255.255.252
Router(config-if)#
Router(config-if)#exit
Router(config)#interface FastEthernet0/0
Router(config-if)#ip address 172.21.3.1 255.255.255.0
Router(config-if)#
Router(config-if)#exit
Router(config)#ip route 172.21.1.0 255.255.255.0 172.21.2.1
Router(config)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to down
1.3. Pinging from the client end
Ping the client's own network interface
9
TCP/IP NETWORKING
Ping the local router gateway interface
Pinging the remote router interface
TCP/IP NETWORKING
Ping the local router gateway interface
Pinging the remote router interface
Secure Best Marks with AI Grader
Need help grading? Try our AI Grader for instant feedback on your assignments.
10
TCP/IP NETWORKING
TCP/IP NETWORKING
11
TCP/IP NETWORKING
Pinging the server
TCP/IP NETWORKING
Pinging the server
12
TCP/IP NETWORKING
1.4. Traceroute command from the client to the server
TCP/IP NETWORKING
1.4. Traceroute command from the client to the server
Paraphrase This Document
Need a fresh take? Get an instant paraphrase of this document with our AI Paraphraser
13
TCP/IP NETWORKING
Task 2- Configuration of the network service
2.1. DHCP
TCP/IP NETWORKING
Task 2- Configuration of the network service
2.1. DHCP
14
TCP/IP NETWORKING
2.2. WEB Server
TCP/IP NETWORKING
2.2. WEB Server
15
TCP/IP NETWORKING
2.3. DNS
TCP/IP NETWORKING
2.3. DNS
Secure Best Marks with AI Grader
Need help grading? Try our AI Grader for instant feedback on your assignments.
16
TCP/IP NETWORKING
2.4. Firewall
Router 0 Configuration:
TCP/IP NETWORKING
2.4. Firewall
Router 0 Configuration:
17
TCP/IP NETWORKING
Bibliography
Cai, W. X., Li, G. S., Chen, X. H., Hong, C. Q., Zhu, S. Z., Wu, Q. H., & Chen, R. (2016, August). Education
based new computer network simulator design and implementation. In Computer Science &
Education (ICCSE), 2016 11th International Conference on (pp. 933-935). IEEE.
Gusev, M., Ristov, S., & Donevski, A. (2014, April). Integrating practical CISCO CCNA courses in the
Computer Networks' curriculum. In Global Engineering Education Conference (EDUCON), 2014
IEEE (pp. 499-506). IEEE.
Hossain, M. A., Islam, M. M., & Majumder, M. N. U. (2016). Comparative Analysis of Two Prominent
Routing Protocols in IPv6 Network: OSPFv3 & EIGRPv6. International Journal of Computer (IJC),
22(1), 79-89.
Khedr, M. E., Zaghloul, M. S., & El-Desouky, M. I. (2015). Wireless Adhoc Multi Access Networks
Optimization Using OSPF Routing Protocol Based On Cisco Devices. International Journal of
Computer Networks & Communications, 7(2), 59.
Prasad, N. H., Reddy, B. K., Amarnath, B., & Puthanial, M. (2016). Intervlan Routing and Various
Configurations on Vlan in a Network using Cisco Packet Tracer. International Journal for
Innovative Research in Science and Technology, 2(11), 749-758.
Sun, L., Wu, J., Zhang, Y., & Yin, H. (2013, April). Comparison between physical devices and simulator
software for Cisco network technology teaching. In Computer Science & Education (ICCSE), 2013
8th International Conference on (pp. 1357-1360). IEEE.
Tagliacane, S. V., Prasad, P. W. C., Zajko, G., Elchouemi, A., & Singh, A. K. (2016, March). Network
simulations and future technologies in teaching networking courses: Development of a
TCP/IP NETWORKING
Bibliography
Cai, W. X., Li, G. S., Chen, X. H., Hong, C. Q., Zhu, S. Z., Wu, Q. H., & Chen, R. (2016, August). Education
based new computer network simulator design and implementation. In Computer Science &
Education (ICCSE), 2016 11th International Conference on (pp. 933-935). IEEE.
Gusev, M., Ristov, S., & Donevski, A. (2014, April). Integrating practical CISCO CCNA courses in the
Computer Networks' curriculum. In Global Engineering Education Conference (EDUCON), 2014
IEEE (pp. 499-506). IEEE.
Hossain, M. A., Islam, M. M., & Majumder, M. N. U. (2016). Comparative Analysis of Two Prominent
Routing Protocols in IPv6 Network: OSPFv3 & EIGRPv6. International Journal of Computer (IJC),
22(1), 79-89.
Khedr, M. E., Zaghloul, M. S., & El-Desouky, M. I. (2015). Wireless Adhoc Multi Access Networks
Optimization Using OSPF Routing Protocol Based On Cisco Devices. International Journal of
Computer Networks & Communications, 7(2), 59.
Prasad, N. H., Reddy, B. K., Amarnath, B., & Puthanial, M. (2016). Intervlan Routing and Various
Configurations on Vlan in a Network using Cisco Packet Tracer. International Journal for
Innovative Research in Science and Technology, 2(11), 749-758.
Sun, L., Wu, J., Zhang, Y., & Yin, H. (2013, April). Comparison between physical devices and simulator
software for Cisco network technology teaching. In Computer Science & Education (ICCSE), 2013
8th International Conference on (pp. 1357-1360). IEEE.
Tagliacane, S. V., Prasad, P. W. C., Zajko, G., Elchouemi, A., & Singh, A. K. (2016, March). Network
simulations and future technologies in teaching networking courses: Development of a
18
TCP/IP NETWORKING
laboratory model with Cisco Virtual Internet Routing Lab (Virl). In Wireless Communications,
Signal Processing and Networking (WiSPNET), International Conference on (pp. 644-649). IEEE.
Yan, D. (2014). Applications of Packet Tracer simulator in the course< Router Configuration. Electronic
Test, 8, 019.
TCP/IP NETWORKING
laboratory model with Cisco Virtual Internet Routing Lab (Virl). In Wireless Communications,
Signal Processing and Networking (WiSPNET), International Conference on (pp. 644-649). IEEE.
Yan, D. (2014). Applications of Packet Tracer simulator in the course< Router Configuration. Electronic
Test, 8, 019.
1 out of 19
Related Documents
Your All-in-One AI-Powered Toolkit for Academic Success.
 +13062052269
info@desklib.com
Available 24*7 on WhatsApp / Email
Unlock your academic potential
© 2024  |  Zucol Services PVT LTD  |  All rights reserved.